This is the new home of the egghelp.org community forum.
All data has been migrated (including user logins/passwords) to a new phpBB version.


For more information, see this announcement post. Click the X in the top right-corner of this box to dismiss this message.

Client Closed Connection after rehash or restart

General support and discussion of Eggdrop bots.
Post Reply
i
illusionist
Voice
Posts: 25
Joined: Mon Mar 09, 2020 11:22 am

Client Closed Connection after rehash or restart

Post by illusionist »

Hello every one..
I hv installed eggdrop 1.9 version
After adding any new tcl script

When i Tried rehash or restart .. eggdrop got disconnected and shows "client closed connection"

After every rehash or restart bot dies and stat the from manually commands ...

Any help
User avatar
CrazyCat
Revered One
Posts: 1233
Joined: Sun Jan 13, 2002 8:00 pm
Location: France
Contact:

Post by CrazyCat »

Which script did you add ?
Did you try removing it from the config file to check if its really faulty ?
i
illusionist
Voice
Posts: 25
Joined: Mon Mar 09, 2020 11:22 am

Post by illusionist »

Yes I tried That Way also...

Removing all My scripts nd just plain eggdrop on IRC but after rehash or restart result is same

** aBot has quit (Client closed connection)
User avatar
CrazyCat
Revered One
Posts: 1233
Joined: Sun Jan 13, 2002 8:00 pm
Location: France
Contact:

Post by CrazyCat »

You remove the script, then restart the bot once (to have it running without the script) and then rehash to check ?
How do you rehash it ? From Party-line ? Can you paste&copy what messages in the PL from your .rehash to the shutdown ?
i
illusionist
Voice
Posts: 25
Joined: Mon Mar 09, 2020 11:22 am

Post by illusionist »

Yes tried whole Process from the beginning

[20:20:24] #la`magie# rehash
Rehashing.
[20:20:24] Writing user file...
[20:20:24] Writing channel file...
[20:20:24] Rehashing ...
[20:20:24] Writing channel file...
[20:20:24] * Last context: tclhash.c/749 []
[20:20:24] * Please REPORT this BUG!
[20:20:24] * Check doc/BUG-REPORT on how to do so.
[20:20:24] * Wrote DEBUG
[20:20:24] * SEGMENT VIOLATION -- CRASHING!
Connection closed by foreign host.
i
illusionist
Voice
Posts: 25
Joined: Mon Mar 09, 2020 11:22 am

Post by illusionist »

May be There's bug or issue with eggdrop 1.9 .... Well after installing eggdrop 1.8 i checked everything ... Its working fine but with 1.9 it shows error
User avatar
CrazyCat
Revered One
Posts: 1233
Joined: Sun Jan 13, 2002 8:00 pm
Location: France
Contact:

Post by CrazyCat »

Probably in relation with https://github.com/eggheads/eggdrop/issues/1180

I personaly never encounter this trouble, but you're not alone.
Post Reply