This is the new home of the egghelp.org community forum.
All data has been migrated (including user logins/passwords) to a new phpBB version.


For more information, see this announcement post. Click the X in the top right-corner of this box to dismiss this message.

Twitch

General support and discussion of Eggdrop bots.
Post Reply
s
skull

Twitch

Post by skull »

Hi,

I've enabled the twitch module and my bot is connected just fine but I have 2 issues:

1) I'm not able to /DCC CHAT mybot: it looks like there's no trace of incoming connection to the bot.

2) Scripts binding to something different from "-" fail to execute. i.e. o|o or n|n

Are those some limitations of Twitch IRC Network?

Thanks
User avatar
CrazyCat
Revered One
Posts: 1233
Joined: Sun Jan 13, 2002 8:00 pm
Location: France
Contact:

Post by CrazyCat »

You'll have more information @ https://docs.eggheads.org/mainDocs/twit ... html#binds
It doesn't seem having particular restriction with the use of flags, but I never tried
s
skull

Post by skull »

But this is what it says:

Because Twitch offers an IRC gateway that significantly reduces traditional IRC functionality, the following binds listed in tcl-commands.doc are not compatible with Twitch. If they are in an existing script you are running that is fine, they just likely won’t do anything.

And I tried with this binding right now and it literally doesn't do anything:

bind pub +m|+m !learn learn_learn

While these other bindings work as intended:

bind pub - "\?\?" learn_explain
bind pub - "\*\*" learn_search
User avatar
CrazyCat
Revered One
Posts: 1233
Joined: Sun Jan 13, 2002 8:00 pm
Location: France
Contact:

Post by CrazyCat »

So your testing user has the global or local +m flag ? Does the eggdrop see him as online ?
what gives a .whois handle_of_user ?
s
skull

Post by skull »

Well, that user is myself and I'm the owner of the bot..

skull yes 2 hjlmnoptx 15:46 (partyline)
User avatar
CrazyCat
Revered One
Posts: 1233
Joined: Sun Jan 13, 2002 8:00 pm
Location: France
Contact:

Post by CrazyCat »

Looks like you're only known as party-line user.
Add your twitch host, or try a .adduser skull (or whatever is your nick on twitch), then the eggdrop will probably recognize you
s
skull

Post by skull »

Thanks, you were right, I needed to add my host on the Twitch network.

I used the .+host <user> <host> command
s
skull

Post by skull »

I don't know what I did, but it's not working anymore :(
My host is set up correctly, the binding is +m|+m but my command doesn't trigger anymore.

bind pub - "\?\?" learn_explain
is still working..
User avatar
CrazyCat
Revered One
Posts: 1233
Joined: Sun Jan 13, 2002 8:00 pm
Location: France
Contact:

Post by CrazyCat »

I don't know how twitch works, didn't you have your host changed ? You probably have to use a less restrictive hostmask
Post Reply