This is the new home of the egghelp.org community forum.
All data has been migrated (including user logins/passwords) to a new phpBB version.


For more information, see this announcement post. Click the X in the top right-corner of this box to dismiss this message.

DCC connect issue with VPN?

General support and discussion of Eggdrop bots.
Post Reply
f
fusionx
Voice
Posts: 30
Joined: Sun Jan 16, 2022 1:35 pm

DCC connect issue with VPN?

Post by fusionx »

Hiyas!

I can CTCP to my bots when I first start them. No issues at all.

When my IP changes because of my VPN, CTCP connects, but I never get a username prompt. I need to restart the bot(s) to get it working again. That's a hassle, as I need to move clients into channels to hold them with Ops, etc..

Rehash and restart don't resolve the issue - I have to kill the process or bot die, then restart, and then it works flawlessly the rest of the day.

Any ideas how I can prevent this from happening? Other than "don't use a VPN", lol :)

Hosted externally, no SSL, using basic DCC/Telnet settings.

Thanks in advance for any insight!
User avatar
CrazyCat
Revered One
Posts: 1233
Joined: Sun Jan 13, 2002 8:00 pm
Location: France
Contact:

Post by CrazyCat »

Probably related to https://github.com/eggheads/eggdrop/issues/1174

Try to set resolve-timeout 0, but no garantee
f
fusionx
Voice
Posts: 30
Joined: Sun Jan 16, 2022 1:35 pm

Post by fusionx »

Thanks very much! This is driving me crazy.. heh..

I tried that, restarted the bots, connected first time with ctcp, and dc'ed. And waited.. my VPN eventually dc'ed me, reconnected right away, and.. can't fully connect with ctcp again. So that didn't solve it.

It's got to be something about the VPN, though I can't see why that would matter at all. We should be able to ctcp from any IP.

Hmmm.. I'm also on ZNC on the same server.. and why that would matter I have no clue. I'm not a networking guy.. or a Linux guy.

I'm not really rambling - lol. Trying to put down my experience in case anyone else is looking for answers.
CrazyCat wrote:Probably related to https://github.com/eggheads/eggdrop/issues/1174

Try to set resolve-timeout 0, but no garantee
w
willyw
Revered One
Posts: 1197
Joined: Thu Jan 15, 2009 12:55 am

Post by willyw »

Can you telnet into the bot's partyline?
If you can, and just sit there, staying connected - maybe you'll see something in the partyline that could be a clue?

Even experiment with the console flags, allowing yourself to see more, sometimes.


Just a thought.....
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !
w
willyw
Revered One
Posts: 1197
Joined: Thu Jan 15, 2009 12:55 am

Re: DCC connect issue with VPN?

Post by willyw »

fusionx wrote: ... as I need to move clients into channels to hold them with Ops, etc..
...

Put two or more bots in those channels. Have them op each other.

( This doesn't solve your original problem - I just couldn't help but say it. :) )
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !
User avatar
CrazyCat
Revered One
Posts: 1233
Joined: Sun Jan 13, 2002 8:00 pm
Location: France
Contact:

Post by CrazyCat »

With your VPN, peharps is it a trouble with your hostmask in the eggdrop
f
fusionx
Voice
Posts: 30
Joined: Sun Jan 16, 2022 1:35 pm

Post by fusionx »

Hi CrazyCat,

Do you recall the setting in the conf you are referring to? I don't see a setting in the full conf file for my IP. Only the vhost settings. The bot is using an external KVM shell, so it's not behind my router, etc.
CrazyCat wrote:With your VPN, peharps is it a trouble with your hostmask in the eggdrop
User avatar
CrazyCat
Revered One
Posts: 1233
Joined: Sun Jan 13, 2002 8:00 pm
Location: France
Contact:

Post by CrazyCat »

Connect to the PL and do a .whois <your nick>
See how the eggdrop knows you (the hostmask you have in it) and check your host on IRC when you are connected with your VPN.
f
fusionx
Voice
Posts: 30
Joined: Sun Jan 16, 2022 1:35 pm

Post by fusionx »

Thanks - I was confused :)

I use Undernet's host mask, and that's how the bot(s) know me - that never changes as long as I'm logged in.
CrazyCat wrote:Connect to the PL and do a .whois <your nick>
See how the eggdrop knows you (the hostmask you have in it) and check your host on IRC when you are connected with your VPN.
Post Reply